티스토리 뷰
728x90
Designer Door Mat
Mr. Vincent works in a door mat manufacturing company. One day, he designed a new door mat with the following specifications:
- Mat size must be N X M. (N is an odd natural number, and M is 3 times N.)
- The design should have 'WELCOME' written in the center.
- The design pattern should only use |, . and - characters.
Sample Designs
Size: 7 x 21
---------.|.---------
------.|..|..|.------
---.|..|..|..|..|.---
-------WELCOME-------
---.|..|..|..|..|.---
------.|..|..|.------
---------.|.---------
Size: 11 x 33
---------------.|.---------------
------------.|..|..|.------------
---------.|..|..|..|..|.---------
------.|..|..|..|..|..|..|.------
---.|..|..|..|..|..|..|..|..|.---
-------------WELCOME-------------
---.|..|..|..|..|..|..|..|..|.---
------.|..|..|..|..|..|..|.------
---------.|..|..|..|..|.---------
------------.|..|..|.------------
---------------.|.---------------
Input Format
A single line containing the space separated values of N and M.
Constraints
Output Format
Output the design pattern.
Sample Input
9 27
Sample Output
------------.|.------------
---------.|..|..|.---------
------.|..|..|..|..|.------
---.|..|..|..|..|..|..|.---
----------WELCOME----------
---.|..|..|..|..|..|..|.---
------.|..|..|..|..|.------
---------.|..|..|.---------
------------.|.------------
문제해석
Vincent라는 사람이 매트를 만든다고 한다. 매트의 사이즈는 반드시 N x M 사이즈인데 아래와 같은 제약 조건이 있다.
- N : 홀수의 정수여야 한다.
- M : N의 3배여야 한다.
매트는 가운데에 'WELCOME'이라는 문구가 들어가도록 디자인하여야 하고, 디자인 패턴은 |, ., - 3가지 문자로 가능하다.
문제풀이
이런 패턴문제는 업무에 쓰일 확률이 없기 때문에,, 그냥 Discussions에서 코드만 확인하였다.
n, m = map(int,input().split())
pattern = [('.|.'*(2*i + 1)).center(m, '-') for i in range(n//2)]
print('\n'.join(pattern + ['WELCOME'.center(m, '-')] + pattern[::-1]))
728x90
LIST
'Programming > Python' 카테고리의 다른 글
[Python/Hackerrank] Strings > Alphabet Rangoli (0) | 2021.12.10 |
---|---|
[Python/Hackerrank] Strings > String Formatting (0) | 2021.12.10 |
[Python/Hackerrank] Strings > Text Wrap (0) | 2021.12.09 |
[Python/Hackerrank] Strings > Text Alignment (0) | 2021.12.09 |
[Python/Hackerrank] Strings > String Validators (0) | 2021.12.09 |
댓글
공지사항
최근에 올라온 글
최근에 달린 댓글
- Total
- Today
- Yesterday
링크
TAG
- string
- SQL Server
- python
- 몰누피라비르
- HK이노엔
- 에코캡
- tensorflow
- mysql
- python3
- 넷플릭스
- 분석탭
- 넥스트BT
- 테슬라
- DATABASE
- hackerrank
- 미중무역전쟁
- 경구치료제
- MSSQL
- 대원화성
- Tableau
- 코로나19
- 리비안
- 매매일지
- list
- 동국알앤에스
- insert
- Weather Observation Station
- MS SQL Server
- TSQL
- 해커랭크
일 | 월 | 화 | 수 | 목 | 금 | 토 |
---|---|---|---|---|---|---|
1 | 2 | 3 | 4 | 5 | 6 | 7 |
8 | 9 | 10 | 11 | 12 | 13 | 14 |
15 | 16 | 17 | 18 | 19 | 20 | 21 |
22 | 23 | 24 | 25 | 26 | 27 | 28 |
29 | 30 | 31 |
글 보관함